Jockey Journal Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter · #1 ·
i took my front wheel off last night to change the fork bushings and when putting it all back together i noticed this little valve or screw deal. i have no idea what it is and should it be covered

 

·
Registered
Joined
·
967 Posts
Not for a Speedo cable, is it?
 

·
Registered
Joined
·
845 Posts
Looks strangely similar to a speedo cable housing on a XS650 front end. :D Cap it off if you're not going to use it just to keep the crud/water out.
 

·
Registered
Joined
·
967 Posts
I'm not familiar with the xs650, but that looks like an oil light sender. Or neutral indicator switch. I'm just guessing now.
 

·
Registered
Joined
·
335 Posts
Ryno said:
It's definitely a muffler bearing.
Keep that shit lubed up or you'll seize your driveshaft.
:D :D LOL!!! Now dont go confusin him... next thing ya know he'll be off trying to hook up the fallopian tubes to the starter diaphragm..
The part that is all melty is the oil light send...Not needed. Its just held on there by a circlip...and no it does not hook up to the part on the axle...
As for the original question, it is the speedo drive..just cap it as was said earlier..
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #11 ·
got it thanks!

thanks larry

XCabbieS said:
:D :D LOL!!! Now dont go confusin him... next thing ya know he'll be off trying to hook up the fallopian tubes to the starter diaphragm..
The part that is all melty is the oil light send...Not needed. Its just held on there by a circlip...and no it does not hook up to the part on the axle...
As for the original question, it is the speedo drive..just cap it as was said earlier..
 
1 - 11 of 11 Posts
Top