Jockey Journal Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,753 Posts
Discussion Starter · #1 ·
Well saturday I road the sporty over to Nads house for some good conversation. We grew bored and decided to motor up to our local pub....after a couple pints and more "good" conversation the clouds rolled in and in and in!! the skys fell out and within 10min the roads were under water the the side walks and almost the front entry to the bar! Our bikes were parked out front and were in the down pour. at one point the water had risen up about half way on the primary covers. hahahahah first ride with my pal and were all wet!!
We stayed inside long after and until the roads dried before making our break....well when this happen the Nads bike was DEAD!!! So for the next 15min I circled him as he recieved several jump starts and hundreds of kicks and words of advice from the bums holding court over his situation hahahahhahahh
the bums built up my ego by telling me over and over how much they liked my bike better then his hahahah they have NO idea huh!
well we got her running and we rolled on out. at the light I asked the Nads if he was cool! and he agreed so we went our seperate was ending a great day!!
 

·
Registered
Joined
·
1,810 Posts
Last night was worse, I went to Brian's birthday bash at the Handlebar and almost lost my bike stopping at a traffic light. The roads were soaking wet and oily and when I hit my (shitty rear mechanical brake) the rear wheel locked and I started losing her from underneath me. I slapped both bald Converses on the ground and managed to keep her up. I was scared shitless.
It was a good time at the bar though, young Matt Zackton wanted to ride my bike in the parking lot, I told him it was cool, and he did a good job, until the end of the parking lot when he almost lost it too.

The ride home truly sucked, I was soaked from head to toe, the rain wouldn't let up and there was worse thunderclouds on the horizon.

I stopped at Will's for a 'come down' pint and went home.

And I didn't get yelled at.
 

·
Registered
Joined
·
1,810 Posts
PS, the starting problem ended up being a binding accelerator pump linkage on the carb and the positive terminal on the battery wasn't letting it charge up.

The bike ran like a champ all day yesterday.
 

·
Registered
Joined
·
1,753 Posts
Discussion Starter · #4 ·
Nads said:
PS, the starting problem ended up being a binding accelerator pump linkage on the carb and the positive terminal on the battery wasn't letting it charge up.

The bike ran like a champ all day yesterday.
sweet nads Im glad she's running better! I cant wait to go on a long haul. NO 300 Indian Jim run but maybe 50 to start haha

Im gonna tackle those turn signals tonight
 
1 - 4 of 4 Posts
Top