Jockey Journal Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
866 Posts
Discussion Starter · #1 · (Edited)
Got the intro done so now comes my barrage of questions! I am having some problems with my '70 sportster, some are related to each other but some are unrelated I think...
Had an S&S super B put on, the bike wont run without the enricher pulled (it will run but not well enough to ride). I assumed a vacuum leak so I sprayed all around the intake seals with WD-40 but the idle did not change, I think the intake is sealed up. We had the motor out so when the intake was installed everything appeared to line up and seal. While the bike runs pretty good with enricher out the plugs foul after 15-20 minutes (a dry, black, sooty fouling, bad enough that the bike will die) I also get a black puff of smoke out the pipes. to me the bike is presenting symptoms of running both lean and rich????
The bike has a magneto that is locked in full advance, as a result it starts pretty hard (acts just like a SBC when the timing is advanced too far) I dont like this as it is very hard on the battery and and the biked isnt equipped with a kick. Is there anything I can do to remedy this? I like the magneto and would like to keep it...is there such a thing as a retro fit electric ignition that fits in the magneto??
Seems to me I've got some tuning issues and would appreciate any and all help...thanks

just thought of a couple more problems...my petcock is kinda suspect, the old one shit the bed so I cobbled one together with Ace Hardware plumbing fittings, it actually looks kinda cool but could this be a problem?
How do you remove Kreem from inside a tank? What is the best substitute to Kreem? It seems like some could be flaking off insided the tank...thanks again
 

·
Registered
Joined
·
257 Posts
Let's see if I can help you out, first the mag, you have a 1970 XLH that was originally a distributor auto advance, some one put a mag on it and did not put the plae that allows for retarding the spark during starting. If you have acess to a parts book for a 1967 to 69 XLCH you will see under the mag there at=re two plates that allow the mag to move, you will need to find then (V twin might repop them) then hook a universal choke cable to retard during starting. Also make sure the timing is right. To do that take out the spark plugs and remove the keeper on the intake front cly push rod tube, remove the carb and timing inspection plug on the left side between the clydrs. put the bike in 4th gear and slowly push it till the intake push rod just comes down at that point you should be able to just turn the push rod, look into the hole and continue till the single line is in the middle of the hole, if you go to far back up and go forward again you want all the slop taken out going the right way. Remove the cover of the mag, there are two cams on the lobe the narrow one at full advance should just START to open the points. If the points are open your timing is too far advanced and will cause problems with your electric start. Next some early super B carbs had a problem that caused piss poor running. Make sure the float is set right and then when looking at the carb from the right side of the bike there may be should be a little tube sticking out of the right side facing and coming into the air cleaner, if not you may have a carb that needs to be modified. I don't remember the exact way to do this (it's been a long time) Sorry to be so long winded but this should get you started in the right direction hope it helps.
 

·
Registered
Joined
·
485 Posts
For the choke problem check out your pilot jet, it may be clogged up. I had the same problem on my sporty ( but it was a 97 with a CV carb, not sure if you have the same carb. ) Once I got the pilot jet cleaned up it started and ran like a dream :)
 

·
Registered
Joined
·
866 Posts
Discussion Starter · #4 ·
great advise, keep it coming...I wonder if there is some kinda lock collar I could use to lock the mag in place after it starts, rather than use a cable?
 

·
Registered
Joined
·
726 Posts
Rip the carb open and clean it out. When I have starting issues I use starting fluid just to get it going and then quickly adjust the idle screw to keep it going and tune from there. Once you get it to idle you want to run the air mixture screw down till it almost dies then run it up till it almost dies then turn it down to the middle ground and that should be your sweet spot. MAke sure you count the turns and write it down somewhere because you will need it again.


Also, make sure you don't have a blown head gasket, I chased the problem for a whole day before I figured it out.
 

·
Registered
Joined
·
675 Posts
does yoru super B have a accelerator pump? if not get one. they run 100% better that way. V twin has them for the super B. Also for the petcock, don't fuck around spend the money and get a pingel. it will make you life so much better down the road
 

·
Banned
Joined
·
163 Posts
email me on the retrofit

on the b...... a 51mm throttle butterfly carb may run on a 90cc engine

but not like a more intelligently sized 34-36mm bore carb will

no reason for a sporty not to start and run crisply...... and never have to concern yourself with not rolling into the throttle too soft or too hard...... while returning at least 60 mpg

just my opinion...... the b is far too large for a 900 cc sporty

which is already behind the eight ball due to it's way overly large intake ports and long rod ratio which does not suffer the resulting low intake velocity...... and of course the engine itself is right on the ragged edge of self destruction where the ports and rod ratio start working together

I think the factory rating on mine is like 60 something horses at a bottom end killing 6800 rpm...... and they don't have much of a useable torque curve with huge carbs..... at least not like they are capable of delivering with more appropriately sized intake components and a smart exhaust
 

·
Registered
Joined
·
866 Posts
Discussion Starter · #8 ·
HackAsaw - sent you an email, let me know if it doesnt get there as I am the process of setting up a new computer / email account and am afraid some things are going twice or maybe not at all??
 

·
Registered
Joined
·
866 Posts
Discussion Starter · #11 ·
leadsled said:
for your tank try that por-15, does your fuel inlet hit your mag which will restrict it's ability to move.
Hackasaw - that address is my work computer, I'll have to get the message Tuesday and I'll get back to you - dont get on the comptuer much on the weekends. I'll check over all my fuel plumbing, I think it is okay but...
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top