Jockey Journal Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
212 Posts
Discussion Starter · #1 ·
Whats going on ? got a 74ci shovelhead with n super e on it. Got the .295 & .72 jet installed. Bike seems to be running pretty good, but plugs stilll indicate alittle richness..What would be recommended as far as jetting or just lean it out from the carb ? Starts failry easy and took it out no coughing popping or stumbling...
 

·
Registered
Joined
·
1,576 Posts
So what's the problem? Shovels like it a little fat. You could try the next smaller size main and see if it leans it out some but it seems you have the right combo.
 

·
Registered
Joined
·
212 Posts
Discussion Starter · #4 ·
seemed like it was running a tad rich, maybe need to take it on a good ride. was just banging around town with jus some 1 & 2 shifts maybe was jus loaded up alil
 

·
Registered
Joined
·
81 Posts
79Shovel; it's important to adjust the accelerator pump on the "E" model. They normally dump too much fuel out of the box.
Jerry
 

·
Registered
Joined
·
692 Posts
What kinda pipes? Muffled? Baffled?

I have an 80" Pan with baffled straight pipes....Im still a bit fat with a .028 intermed/.070 main at 1-1/4 turns with Accel pump turned off completely.

Im thinking .072main might be a little fat for you. Hows the throttle response above 45mph?
 

·
Premium Member
Joined
·
7,101 Posts
Look for my post on modifying the super E, if you cant find them P.M. me and I will explain, your accell pump is sending a false idel circut and making it look rich.....Roach.
 
1 - 12 of 12 Posts
Top