Jockey Journal Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
131 Posts
Discussion Starter · #1 ·
BUT, one problem solved.

The problem I was having for the last few months was that the battery wasn't charging. turned out it was the stator wires being broken inside of the primary cover. Great. THAT was easy. Now, whenever I hit the brake light, the bike shuts off. same with the head light being hooked up. dead. I'm hoping that its the battery just being weak, which it is (I think) I only had it charging up a little while. I'm hoping that a fresh battery cures this. But, at least now its charging again. Its a Boyer E.I. set up, by the way. What do you guys think?..


Spike
 

·
Registered
Joined
·
287 Posts
Spike! said:
BUT, one problem solved.

The problem I was having for the last few months was that the battery wasn't charging. turned out it was the stator wires being broken inside of the primary cover. Great. THAT was easy. Now, whenever I hit the brake light, the bike shuts off. same with the head light being hooked up. dead. I'm hoping that its the battery just being weak, which it is (I think) I only had it charging up a little while. I'm hoping that a fresh battery cures this. But, at least now its charging again. Its a Boyer E.I. set up, by the way. What do you guys think?..

Spike
Fresh battery should cure this. Think about it.... Since tha battery is low, all the "juice is going to keep the ignition sparking. When you step on the brakes, or turn on the lights, it diverts enough "juice" to the lights to kill the ignition. If thats not it, triple check your grounds.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top