Jockey Journal Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Basically the bike ran great last 4 months since purchase and is a easy starter 2/3 kicks cold and 1/2 kicks when hot. I was crusining and slight backfire and bike shut down and would not start. I discovered no spark. I replaced the coil, condenser and points all with Morris parts. I have no fire and I can put my fingers on coil contacts and kick it over and feel a slight slight trickle. I have called Morris themselves(awesome people btw). They are stumped and said to send it in. I have also disconnected the kill switch pole to make sure its not grounding and still nothing. Only thing I can figure out is the magnetic demagnetized? The shaft does turn so not sheared gear on shaft. Any ideas?? I have no idea of age of magneto or magnet. The housing is the old cast and external set screws for coil. Pics of inside of housing showing the magnet. The bike is S S Sidewinder 93" Panhead with Delkron lower cases.
 

Attachments

·
Moderator
Joined
·
4,030 Posts
You don't have a spare coil you might be able to swap in, do you?
 

·
Moderator
Joined
·
4,030 Posts
Sorry, missed that in the original post.
 

·
Moderator
Joined
·
4,030 Posts
I would be curious to hear what happens, if you got time to fill us in on the gory details.

Dave's a pretty helpful feller.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #8 (Edited)
Okay guys just got off phone with Barry at Morris Magnetos. Once again these guys are great. The direct problem was I had old magnet variable and not the new "rare earth magnet". The magnet had lost all of its MOJO. Also the top bearing needed replacement. Furthermore they are backed up(Covid) but I did manage to buy a new trade in unit they had. I will have old unit that will need to be rebuilt but I will post it on here for sale for parts(not looking to make any money off of it). If anybody is basically looking for a old version housing send me a message. I will post a update when I get new unit and install. Ordered the buzz box as well.
 

·
Registered
Joined
·
1,685 Posts
Ahh,

Makes a lot of sense. Mags are pretty fool hardy when they're setup right, and I mean, you checked everything else I guess!

Be back on the road in no time.
 

·
Moderator
Joined
·
4,030 Posts
Funny it lost its magic sparkles all at once.

Buzz box is a must-have, IMO.
 

·
Registered
Joined
·
258 Posts
I have a suspicion that most people hate their magneto because they weld on the bike with the magneto mounted and mess up the magnet. I had a lot of problems until I had mine remagnitized at an airplane mechanic.
 
1 - 11 of 11 Posts
Top