Jockey Journal Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2,035 Posts
Discussion Starter · #1 ·
There are plenty of you that have had trouble getting a Lucas to work right:D, but have any of you had one that would not QUITE:mad:?
I have a Lucas K2FC mac that can not be shut off. It is freshly and completely built/remgnetized, new armature w/modern condensor by Beno Rodi (very reputable racer, Brit expert, and has also never heard of this problem). This mag functioned perfectly from the start. I used a switch from the cap (same as many times before) to ground to shut it off, which worked fine for the first few dozen miles. I have had the cap off, while running, and put a wrench from the center contact on points plate to the primary (it does show sparks, so is getting contact) as well at the motor case, while this should kill it, it continues to run. This test takes the cap and cap-brush out of the equation. I have removed the center stud, wire brushed the whole thing including threads spotless as well as the head that the cap brush contacts, and cranked it all back together...it still runs. Beno says if this center stud had any continuity issues from the armature to the points plate, the mag would not fire.
Since elctrons take the course of least resistance, I wonder if opening the plug gap a bit may make the path though the brush, cap, wire and switch that easier path? But I have never had adjust the plug gap on any other rebuilt Lucas mag bike to get it to shut off. I am sure there is some underlying issue that I am missing.
Have any of you guys had a Lucas K2FC that refused to die?
Thanks, Dan.
 

·
Registered
Joined
·
2,035 Posts
Discussion Starter · #6 ·
Tony,
Thank you, thank you, thank you! You are the man! That was exactly it. I guess next time I get a mag fully rebuilt, I'll replace all the brushes myself, after the fact :D
Cheers, Dan.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top