Jockey Journal Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #4 ·
It is a '78. My brother an I put the engine all back together, I had the trans assembled by a local guy. I shortened the rear fender, added the '37 Ford taillight, and the Mustang scooter tank. I did the paint work on it, black with metallic red scallops to match my Model A coupe. Big Ric did the pinstriping. I bought it as a rolling chassis, the bottom end of the engine was assembled, everything else was in boxes. The guy I bought it from had all the machine work done and had all the new parts to put it together, but lost interest in it. He had already redone the suspension and brakes. I'm having trouble with the clutch, as soon as I get that worked out I can finally get some miles on it.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #8 ·
BLAKE said:
Lookin' good, Rodney, but where's them wheels I got ya?

I say we get a group ride up to FlyRite open house next Saturday.
I'm gonna have to have the front one relaced to my hub to make the front brakes work, I should have the rear one back tommorrow. I gave it to a friend of mine that works at Mancuso to have the new rear tire put on and put the new wheel bearings in it. I'd bought the bearings for the other wheel I had, so figured might as well put them in. I had the primary cover off again tonight, working on the damn clutch. At first, I had too thick of oil in the primary, and the clutch discs were sticking together and not releasing. Took the cover off, built a tool to get the clutch apart, took it apart, cleaned all the discs, put it back together. Now it is releasing, but still dragging a bit, think it just needs to be adjusted a little now. Once that is sorted out, I need to fine tune the engine a bit. I'm going to get my insurance and tags in the morning.
 
1 - 8 of 8 Posts
Top