Jockey Journal Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
692 Posts
Discussion Starter · #1 ·
Anyone encounter any BDL clutch hub wobble or wonkiness when torqued to a non-splined, tapered mainshaft? I see from recent searches that clutch wobble has been encountered on splined shafts. But I see nothing in regards to tapered shafts

I have a significant wobble and thought it may be due to bent mainshaft or clutch hub to mainshaft fit, but I've ruled both out.

This clutch assembly was mint before disassembly to fix a seal leak. When bolted back on, I had a noticeable wobble in the clutch hub/basket.

Be damned if I can sort this out and am hoping that the inner hub or sealed bearing didnt go south simply by being disassembled.

Anyone have any experience with BDL clutch assemblies being fraught with problems??
 

·
Registered
Joined
·
732 Posts
EDIT.. I dont have the BDL Competitor Clutch Hub..

this is how myine looks





i had mine of the gearbox (tapared shaft) this winter when i rebuildt the engine and other parts..

my plan was to change the bearing but i couldnt find any that i liked (quality)
so i just remounted it as it was.. didnt wobble at all..

have you tryed to remove the "clip" that holds the bearing and gently press it in its seat again?

maybe it have moved when you took it of the gearbox?
i had to use quite alot of force before it "popped" loose.. scared the shit out of me when it did!

dont know if that helps but thats the only thing i could think of..

good luck and i hope you solve it // Kenneth
 

·
Registered
Joined
·
692 Posts
Discussion Starter · #3 ·
Thanks, Ken...

I did remove the C-clips that hold the bearing to the hub...they were a mutherfucker to get out. Bearing was fine from I can determine and re-seated the clips...no issues there.

Cleaned a minor bur in hub keyway and took off a few thou on the woodruff key thinking the hub wasnt fitting quite right to the taper...no change in the wobble there either.

Gonna try my old 5-fingered hub with this clutch basket tonight to determine any difference.
 

·
Registered
Joined
·
1,047 Posts
Perhaps the key is sitting tall or off to one side of the key-way and not letting the hub seat fully on the shaft..???
Took the words right out of my mouth. Try mounting it without a key at all (temp of course) and see if you've still got the wobble. If the key is pushing up the keyway, it will never seat properly and it WILL crack the hub if you torque it down like that.

-Kuda
'49 panchop
 

·
Registered
Joined
·
692 Posts
Discussion Starter · #6 ·
Yes, did all of the runout tests....

-Mainshaft has .004" runout (at the threads, neck, and just aft of the keyway)
-BDL inner clutch hub bearing has .004" runout
-Clutch assembly when torqued to mainshaft (measured at O.D. of clutch basket) has ~.012" runout
-Clutch assembly when sitting on the bench (measured at O.D. of clutch basket) has ~.012" runout

I cannot measure the inner bearing surface of the clutch basket as I dont have a lathe I can bolt it to to spin it up and check the runout.

I dressed the key a few thou thinking that the key was too tall. That did virtually nothing to the runout of the assembly. The BDL inner clutch hub appears centered on shaft, and when torqued to spec doesnt cause key to move and hub just barely comes to a rest at the end of the mainshaft taper.

I mounted the inner clutch hub and then full clutch assembly, separately, to the mainshaft without the key...the runouts listed above are the same in both situations.

There still is a noticeable wobble that is now affecting clutch engagement. It was NOT there before the disassembly.

The only thing I changed in this R&R of the clutch assembly was to add an outboard mainshaft support bracket and replace a worn mainshaft seal.

Checking mainshaft runout with outboard bearing support ON and OFF...runout is still the same at .004". Unless Im crazy, it aint the mainshaft thats the problem...I think.

When I torqued my 5 finger clutch hub to the mainshaft without the clutch basket, the runout on the hub was .004". I will throw on the clutch basket and roller bearings tonight and check the runout as an assembly to see if there's still a wobble. If so, then I guess it must be the mainshaft. If not, then its the BDL inner clutch hub and bearing thats tweaked.

Any other ideas or directions? Im all ears.
 

·
Registered
Joined
·
692 Posts
Discussion Starter · #8 ·
Nope....torque wrenches, ratchets and elbow grease to both torque and remove.

It looks like the inner clutch hub is shot/out of round or some shit...

I bolted the 5 finger clutch hub assembly to mainshaft...virtually no runout and no wobble, so its not the mainshaft or the key.

Somehow, someway, the BDL clutch hub is tweaked. Beats the fuck out of me how by simply unbolting it from the mainshaft it went to shit?
 

·
Registered
Joined
·
1,188 Posts
Kevin,

Here's what I do to investigate keyed taper fit problems. You may already be past this point, but here it is:

Clean both tapers thoroughly with solvent.
Paint the shaft taper with layout dye and let it dry.
Assemble the parts carefully WITHOUT they key, making sure not to rotate at all.
Torque down the fastener to spec.
Remove the fastener and pull the assembly apart with the appropriate puller.
Inspect the dye markings on the shaft.

Markings should be uniform. Intermittent or uneven appearance of bare and dyed portions show poor taper fit (high spots and low spots).

For cases where problem only exists with key, do this test WITH the key installed. Bet you'll find a bunch of untouched dye around the side of the shaft that holds the key. This means the key is too tall. I've had to take upwards of .080" off some keys (maybe i used the wrong one in some cases, but they can still be made to work).

The other most common issue is deformation of the keyWAY on the shaft. The metal stands proud at the edges making a high spot and poor fit. A loose assembly can lead to this problem where the two parts move under force and waller out (technical term) the keyway. Clean it up with a file. This could still be your problem even though the oem hub fits fine. Different hubs have different features/clearances around the keyway.

Another thing that occurred to me (and maybe it's because I'm not reading clearly enough) is that the wobble is really in the shell and not in the hub. This is expected due to the bearing clearances. Is .012" reading taken at the hub or the shell? With clutch springs and pack installed, the wobble will most likely go away due to force exerted on the shell towards the inboard side of the bike.

Loose tolerances add up, sometimes not linearly. .004" TIR at shaft plus .004" at hub could easily result in .012" total when assembled. Think levers and triangles.

Anyway, some more things to think about.

Jason
 

·
Registered
Joined
·
2,315 Posts
Good stuff, Jason. I don't have a problem that I know of with my hub, but I'd like to try this and see if there is something I don't see with the naked eye.
 

·
Registered
Joined
·
2,903 Posts
I think Jason nailed it, if the inner hub fits tight, the bearing between the inner and outer hub is good, put the steels, disks and presure plate back on and re check. Could be wrong but, sounds like ya freaked your self out a little.
 

·
Registered
Joined
·
732 Posts
0.012" wobble... that doesnt sound much in my ears...

where do we get specs?

i may be wrong? BDL makes great stuff but i dont think its any better then that after it has been used for a while.

Edit: just read what Jason said in the end... think he is right!


cheers
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top