Jockey Journal Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Built the 110 back in the early 80s from the wheels. up parts were easy to come by then and not too expensive .turned out close to factory. got age related plate and ran it for years no trouble .then other bikes came along and it was mothballed .This year I re commissioned it. polished the iron head combustion chamber. all the engine internals were good. rebuilt K2f commutator and Mag. new Amal 376 carb .back on the road it went like stink ! in the past it was always a first kick starter. but now it is reluctant to start up and will not respond to the throttle when it does start . It would seem that I have checked everything at least three times all to no avail. .The only thing that I did have concern with was the drive end oil seal on the Mag.these seem a very poor design that had let in a lot of oil when compared with the 'old' ones I have since found out sealant is recommended on the seal but as the Mag produces a good spark both on and off the bike I am at a loss. would it be worth having the mag checked out by specialists or should I discount it as being ok. ? Thanks in advance...Rich.
 

·
Registered
Joined
·
1,418 Posts
It might be a good idea to have the may checked out. I had on on my AJS that was failing when it got warmed up.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
It might be a good idea to have the may checked out. I had on on my AJS that was failing when it got warmed up.
That is the thing I have had this happening before 'fading when hot ' on the BB33 . The commutator on the K2f was rewound very recently ?
 
1 - 6 of 6 Posts
Top