BSA Wont Start - No Power after backfire - The Jockey Journal Board

Go Back   The Jockey Journal Board > General Discussion > The Board

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 12-22-2014, 06:42 PM   #1
PaulWallace
Junior Member
 
Join Date: Dec 2014
Location: Cape Cod Ma
Posts: 6
Default BSA Wont Start - No Power after backfire

Hi All,

Hears the situation - I just tore down a 1970 bsa lightning engine and totally rebuilt it. I got it back together and it fired right up. Pulled hard and everything felt good. The next day I took it down the street and it backfired and then I had no power. The headlight wouldn't even come on. I got it back home and pulled the fuse that comes off the negative on the battery and it was bad so I replaced it. Still no power.

I also smelled burning electrical right after it happened. I think something must have shorted out that caused it to backfire. I'm thinking that my wires coming off the stator may have been flipped as they are identical and I didn't know which way to re-connect them. It ran good so I figured they were all right (In hidsight this doesn't make any sense.)

Now when I have the trickle charger on the bike the volt meter on the headlight buries itself to the left (negative) and the trickle charger itself makes a buzzing sound (not comforting).

I'm also thinking that it could have something to do with the rectifier as it is the originaly unit.

Any insight/direction would be greatly appreciated.

Cheers,

~Paul
PaulWallace is offline   Reply With Quote
 

Tags
a65, no power

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 06:45 AM.