BSA Wont Start - No Power after backfire - The Jockey Journal Board

Go Back   The Jockey Journal Board > General Discussion > The Board

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-22-2014, 06:42 PM   #1
PaulWallace
Junior Member
 
Join Date: Dec 2014
Location: Cape Cod Ma
Posts: 6
Default BSA Wont Start - No Power after backfire

Hi All,

Hears the situation - I just tore down a 1970 bsa lightning engine and totally rebuilt it. I got it back together and it fired right up. Pulled hard and everything felt good. The next day I took it down the street and it backfired and then I had no power. The headlight wouldn't even come on. I got it back home and pulled the fuse that comes off the negative on the battery and it was bad so I replaced it. Still no power.

I also smelled burning electrical right after it happened. I think something must have shorted out that caused it to backfire. I'm thinking that my wires coming off the stator may have been flipped as they are identical and I didn't know which way to re-connect them. It ran good so I figured they were all right (In hidsight this doesn't make any sense.)

Now when I have the trickle charger on the bike the volt meter on the headlight buries itself to the left (negative) and the trickle charger itself makes a buzzing sound (not comforting).

I'm also thinking that it could have something to do with the rectifier as it is the originaly unit.

Any insight/direction would be greatly appreciated.

Cheers,

~Paul
PaulWallace is offline   Reply With Quote
Old 12-24-2014, 05:06 PM   #2
ogresdad
Senior Member
 
ogresdad's Avatar
 
Join Date: Apr 2009
Location: NorCal
Posts: 250
Default Re: BSA Wont Start - No Power after backfire

The Zener sounds to be shorted, when an over current instance occurs the regulator will cause the diode to conduct to ground to "bleed off" un-needed current. Just disconnect the Zener and see if it will fire.
ogresdad is offline   Reply With Quote
Old 12-29-2014, 05:01 PM   #3
Goldy
Senior Member
 
Goldy's Avatar
 
Join Date: Nov 2009
Location: Near Peggy's Cove, Nova Scotia
Posts: 1,381
Default Re: BSA Wont Start - No Power after backfire

you sure you are hooking the battery up with the correct polarity?
__________________
This too shall pass.
Goldy is offline   Reply With Quote
Old 12-29-2014, 05:46 PM   #4
PaulWallace
Junior Member
 
Join Date: Dec 2014
Location: Cape Cod Ma
Posts: 6
Default Re: BSA Wont Start - No Power after backfire

Okay, so I've got it sorted out.

Its a positive ground so the battery was in correctly.

I had left two wires connected to the zener diode grounded. I disconnected them from the diode and took them off the ground(redundant, I know) and I've got power without blowing fuses.

Kicked it over and it fired a few times. If it wasn't 30 degrees and dark out I'd continue but for now I am satisfied.

Thanks for the help. You'll probably hear from me soon.

Cheers.

~Paul
PaulWallace is offline   Reply With Quote
Reply

Tags
a65, no power

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 03:10 PM.